Újabb PHP bugfix, kinn az 5.4.19 és az 5.5.3

A mai napon ismét bugfix érkezett a PHP 5.4 és 5.5 ágain. Nem újabb hibát találtak, csak a napokban javított  CVE-2013-4248 számú, OpenSSL modult érintő biztonsági hiba javításában fedeztek fel egy apróbb bugot.

PHPAz 5.5 ágra történő átállás továbbra sem javasolható, de szerencsére az 5.4 ág karbantartása sem szorult még háttérbe. Az előnyei vitathatóak, de a különböző Linux disztribúciók (főként a Debian/Ubuntu irány) nem arról híresek, hogy ész nélkül állnak át az újabb kiadásokra. Néha már-már nevetséges, ahogy egy már nem támogatott verzióhoz backportolják a hibajavításokat, és ezzel a lusta rendszergazdák igazi mentsváraivá válnak.

Zárszóként, a frissítés hamarosan elérhető lesz minden disztribúcióhoz, a telepítése minden érintett rendszeren javasolt!

Hivatkozások:

http://www.php.net/ChangeLog-5.php#5.4.19

Kategória: Hírek Címke: , , ,
4 comments on “Újabb PHP bugfix, kinn az 5.4.19 és az 5.5.3
  1. Taki szerint:

    Hali!

    Tudsz valami normalis megoldast freebsd-re php53-rol php5 (=5.4) upgrade-re?

    Taki

  2. MadAdmin szerint:

    Szerintem erre nincs igazán jól járható megoldás.

    Én a FreeBSD 8 => 9 átállással, azaz teljes installal ejtettem egybe a dolgot. A virtualizáció kényelmessé tette ezt, mert az új és régi VM a teszt/átállás alatt párhuzamosan futhatott.

    5.3 => 5.4 átállás nem halálos, de egy-két dolog azért változott, lehetetlen mindent normálisan átnézni úgy, hogy közben a rendszer áll emiatt.

  3. Taki szerint:

    A kodok a legkevesbe erdekelnek, a csomagok frissitesere nincs normalis megoldas, legalabbis meg nem talaltam semmit 🙁

  4. MadAdmin szerint:

    Jah, arra nincs. A portupgrade és társai szerintem is felejtősek. 🙂

Vélemény, hozzászólás?

Az email címet nem tesszük közzé. A kötelező mezőket * karakterrel jelöltük

*